Spaces in Column Names

May 16, 2013 at 8:39 PM
I have Fusion Charts installed on a SP2010 Foundation platform and it is working great with one exception. If a column I am trying to use for a X axis has a space in the name, Fusion will not count the data. I can get around the issue by creating a calculated column that has a space free name and then copy the data [origColumnName] from the original column. But that really is not a good solution.

I have tried using "" and '' with no luck. I also tried using the Column_x0020_Name format that shows up in the error, it also did not work.

Any ideas?


Jun 15, 2013 at 8:12 AM
Jun 17, 2013 at 4:53 PM
That seems like a really generic reply. I assumed I was incorrectly typing the column field. Are you say this is a bug?

Here's the information you requested:
  1. SharePoint 2010 Foundations
  2. Windows Server 2008r2
  3. N/A
  4. Yes
  5. Attempted to reference a column name that has a space in it for the X Axis.
  6. Expect to be able to associate a column named with a space in the X Axis.
  7. Error is displayed that the chart is not able to find the column named with a space.
  8. No error is displayed, it just does not show the associated data. The chart shows "No data to display". Like I said above I can get around the issue by creating a calculated column.
  9. Did not find an associated ULS log entry.
I have a feeling it is something I am doing incorrectly when trying to chart information stored in a column that has a space in its name.
Jul 9, 2013 at 4:33 PM
I too am seeing the exact same issue as Nerdcentric.
Aug 11, 2013 at 9:26 AM
Edited Aug 11, 2013 at 9:58 AM
This may depend on which version you are using - I'm not sure (*). But you omitted to say which version you're using -- isn't that perhaps the most important basic piece of information to supply with any bug report or request for help?

Because I have limited time, I feel I must prioritize, so I tend to focus on the issues that contain at least basic information.
  • I think the original code used the field display name, and I think at some point I changed it to use the field internal name, to avoid the insoluble conflict that would arise if there were duplicate field display names.
Try using the field internal name, and see if that works?

Here is an article on finding the internal name of a field:
Aug 11, 2013 at 11:17 AM
Better yet, try the new version (that I just created & made available), using field display name.